Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 18, 2024 - 05:00 BST
Scheduled
Please be aware that the Trust Item Check 0411 will be undergoing maintenance activities during the date and times stated. This service will be unavailable during this time however this will not impact the completion of your ID3global transactions.
We apologise for any inconvenience.
Posted Sep 17, 2024 - 12:22 BST
This scheduled maintenance affected: GBG ID3global (Trust Core (0411)).