Compliance - Slight Service Degradation to UI and GO
Incident Report for GBG
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 11, 2024 - 21:48 BST
Update
We are continuing to investigate this issue.
Posted Jul 10, 2024 - 03:54 BST
Update
We are continuing to investigate this issue.
Posted Jul 10, 2024 - 03:53 BST
Investigating
The compliance platform is currently experiencing technical issues which may result in slower user interface load times, affecting your ability to browse and search for applications and transactions. Our team is working diligently to resolve these issues. We appreciate your patience and understanding.

We will notify you as soon as the service is fully restored.
Posted Jul 10, 2024 - 03:50 BST
This incident affects: GBG Compliance (EDNA - US, IDV - US, ACAS - US).