Issue resolved Start Date and Time - 11 December 2025 — 12:25PM AEDT End Date and Time - 12 December 2025 — 9:30AM AEDT
Posted Dec 11, 2025 - 22:49 GMT
Investigating
Please be advised that GBG Support teams have identified an increase in system errors and/or latency which may cause brief interruptions to the services listed below.
Posted Dec 11, 2025 - 02:33 GMT
This incident affected: GBG Cloudcheck (Australian Passport).