Service Disruption - greenID - DVS Production Visa

Incident Report for GBG

Resolved

Service restored.
Posted Jun 17, 2020 - 13:27 BST

Investigating

We are still experiencing intermittent disruption from DVS Production Visa data source that may be preventing you from using our service.

Sorry for any inconvenience.
Posted Jun 16, 2020 - 23:41 BST
This incident affected: GreenID (DVS - Visa Verification).