We're pleased to inform you that the service disruption has now been resolved and users should be able to use the system as normal.
The incident duration was between 2025/10/21 10:00 UTC to 2025/10/27 19:00 UTC
To customers that have been affected by this issue, we would again like to apologies.
Posted Oct 29, 2025 - 20:13 GMT
Update
We have made internal upgrades, but we are still monitoring until the issue is resolved.
Next Update: October 29, 2025 1:00 PM PDT
Posted Oct 29, 2025 - 17:35 GMT
Monitoring
We have stability but we are still monitoring until the issue is resolved.
Next Update: October 29, 2025 8:00 AM PDT
Posted Oct 29, 2025 - 13:55 GMT
Update
We have stability but we are still monitoring until the issue is resolved.
Next Update: October 29, 2025 8:00 AM PDT
Posted Oct 29, 2025 - 00:06 GMT
Update
We have stability but we are still monitoring until the issue is resolved.
Next Update: October 28, 2025 5:00 PM PDT
Posted Oct 28, 2025 - 19:48 GMT
Update
We have stability but we are still monitoring until the issue is resolved.
Next Update: October 28, 2025 8:00 AM PDT
Posted Oct 28, 2025 - 01:56 GMT
Update
We have stability but we are still monitoring until the issue is resolved.
Next Update: October 27, 2025 5:00 PM PDT
Posted Oct 27, 2025 - 20:00 GMT
Update
We have stability but we are still monitoring until the issue is resolved.
Next Update: October 27, 2025 1:00 PM PDT
Posted Oct 27, 2025 - 15:46 GMT
Update
We have stability but we are still monitoring until the issue is resolved.
Next Update: October 27, 2025 8:00 AM PDT
Posted Oct 25, 2025 - 01:08 BST
Investigating
We are still investigating, as of the temporary corrective actions we have tried have not made any difference we can observe.
We will update you October 24, 2025, at 4:00 AM PDT or as soon as we can confirm the issue is resolved.
Posted Oct 24, 2025 - 19:52 BST
Update
We will continue monitoring the issue and will update you once we confirm the issue has been resolved.
We will update you October 24, 2025, at 12:00 AM PDT or as soon as we can confirm the issue is resolved.
Posted Oct 24, 2025 - 16:07 BST
Monitoring
We are testing a potential solution by over provisioned the biometrics service. Users should be able to complete transactions as normal following this fix. We’re monitoring the platform closely to ensure the service is functioning as expected.
We will update you October 24, 2025, at 8:00 AM PDT or as soon as we can confirm the issue is resolved.
Posted Oct 24, 2025 - 00:13 BST
Investigating
Please be advised that we are experiencing an intermittent service disruption that may result in customers receiving system errors when using the EU_PRODUCTION - Biometrics listed below.
We apologize for the impact this may be having on your business. Our incident team are working hard to identify and fix the root cause as quickly as possible. Further updates to follow.
Next update will be 4:10 PM PDT.
Posted Oct 23, 2025 - 22:12 BST
This incident affected: AssureID Connect (Biometrics - EU).