Service Disruption - ID3 UK Geo Affordability (0392)
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 09:17 – 18:36 BST 29/09/2021
Posted Sep 30, 2021 - 07:56 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Sep 29, 2021 - 16:36 BST
This incident affected: GBG ID3global (UK Geo Affordability (0392)).