We're pleased to inform you that the service disruption has now been resolved and users should be able to use the system as normal.
Start Date and Time • 20 November 2025 — 9:10PM AEDT
End Date and Time • 21 November 2025 — 3:12PM AEDT
To customers that have been affected by this issue, we would again like to apologise.
Posted Nov 21, 2025 - 04:14 GMT
Identified
Note - this outage is affecting only documents from Western Australia.
Posted Nov 20, 2025 - 22:26 GMT
Investigating
Our supplier is currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your business and we’re working with our supplier to get this back up and running.
Posted Nov 20, 2025 - 22:17 GMT
This incident affected: GBG Cloudcheck (Australian Birth Certificate, Australian Marriage Certificate, Australian Name Change Certificate).