Service Disruption - ID3Global - Sweden Personal ID (0215) - Sweden Population (0213) - Sweden Population (DOB) (0214)
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 10:13 – 10:55 BST 10/09/2020
Posted Sep 10, 2020 - 11:11 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Sep 10, 2020 - 10:48 BST
This incident affected: GBG ID3global (Sweden Personal ID (0215), Sweden Population (0213), Sweden Population (DOB) (0214)).