This incident has been resolved. We apologize for the inconvenience caused and will conduct a thorough investigation to prevent similar issues from occurring in the future.
Posted Aug 06, 2025 - 02:40 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 06, 2025 - 02:32 BST
Update
We are continuing to investigate this issue.
Posted Aug 06, 2025 - 01:52 BST
Investigating
We are currently experiencing a service disruption that may be preventing you from using our service. We have been made aware of intermittent errors while using the greenID Admin Panel. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Aug 06, 2025 - 01:39 BST
This incident affected: GreenID (GreenID Admin Panel).