Service Disruption - Loqate – Account Section
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 09:00 - 11:24 GMT 02/01/2025
Posted Jan 02, 2025 - 11:35 GMT
Identified
GBG support teams are investigating an issue with Account Section, which may be preventing customers from topping up accounts.

Investigation is ongoing to resolve this as soon as possible but if you are affected by this, please contact GBG Customer Support.
Posted Jan 02, 2025 - 10:12 GMT
This incident affected: Loqate (Account Section).