Service Disruption - ID3Global - 0324 - Hong Kong Population
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 13/09/2020 Approx. 12:36 BST - 21/09/2020 Approx. 09:20 BST
Posted Sep 21, 2020 - 09:40 BST
Update
We are working with our service provider to resolve the issue. We apologise for any disruption you may have experienced.
Posted Sep 19, 2020 - 12:00 BST
Update
Discussions are still ongoing with the supplier to find a resolution to this service issue. We apologise for any disruption you may have experienced.
Posted Sep 18, 2020 - 12:01 BST
Update
There has been a network issue identified between our service and the suppliers. We are working with the supplier to resolve this. The service remains intermittent whilst we continue to work on this.
Posted Sep 17, 2020 - 13:02 BST
Update
We are still in discussions with the supplier regarding a resolution. We apologise for any service disruption you may have experienced.
Posted Sep 17, 2020 - 09:26 BST
Update
We are continuing to work on a fix for this issue.
Posted Sep 16, 2020 - 12:59 BST
Update
Unfortunately we are still experiencing a service disruption that may be preventing you from processing transactions for Hong Kong. We’re in contact with our supplier and working hard to get this up and running.
Posted Sep 16, 2020 - 09:20 BST
Identified
Unfortunately, the service issue is ongoing. We apologise that this issue is taking longer to resolve than we would like.
Posted Sep 14, 2020 - 18:00 BST
Update
We are continuing to investigate this issue.
Posted Sep 14, 2020 - 15:16 BST
Update
We are continuing to investigate this issue.
Posted Sep 14, 2020 - 12:00 BST
Update
We are continuing to investigate this issue.
Posted Sep 14, 2020 - 09:00 BST
Investigating
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Sep 14, 2020 - 03:48 BST
This incident affected: GBG ID3global (Hong Kong Population (0324)).