We're pleased to inform you that the service disruption has now been resolved and users should be able to use the system as normal. A root cause analysis report containing further detail around the problem cause and resolution will be shared with you shortly.
The incident duration was between 16:00 GMT – 22:20 GMT 29/10/2025
To customers that have been affected by this issue, we would again like to apologize.
Posted Oct 29, 2025 - 22:37 GMT
Identified
Microsoft has confirmed they are continuing to work on implementing a fix for the issue. We are closely monitoring the situation and will provide further updates as soon as more information becomes available. Thank you for your patience and understanding.
Posted Oct 29, 2025 - 20:18 GMT
Update
Initial investigations into this suggest that this is related to a global service incident relating to Microsoft Azure services. Updates regarding this wider incident can be found here: https://azure.status.microsoft/en-gb/status
We will continue to update you regarding the status of the service as we receive news.
Posted Oct 29, 2025 - 17:07 GMT
Investigating
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Oct 29, 2025 - 16:26 GMT
This incident affected: GBG ProID (ProID - ID Verification, ProID - Liveness Verification, ProID Portal v1, ProID Portal v2).