Service Disruption - Loqate – Verify

Incident Report for GBG

Postmortem

We experienced an issue with some Verify endpoints, which resulted in a brief outage to service.

This incident was caused by a planned update that led to unexpected issues, resulting in temporary unavailability of our services. We understand the inconvenience this may have caused and sincerely apologise for any disruption to your operations.

Our technical teams promptly identified the problem and restored the service.

We want to reassure our customers that we are actively taking steps to prevent this type of incident from happening again. Multiple actions are being implemented to improve our processes and ensure greater reliability.

Thank you for your support whilst we worked to resolve this.

Posted May 02, 2025 - 12:35 BST

Resolved

We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 12:46 – 13:13 BST DATE - 01/05/2025
Posted May 01, 2025 - 13:22 BST

Update

We are continuing to investigate this issue.
Posted May 01, 2025 - 13:07 BST

Investigating

Please be advised that we are experiencing a service disruption that may result in customers receiving system errors when using the Loqate services listed below.

We apologise for the impact this may be having on your business. Our incident team are working hard to identify and fix the root cause as quickly as possible. Further updates to follow.
Posted May 01, 2025 - 13:04 BST
This incident affected: Loqate (Verify, Loqate SaaS Platform, Everything Location).