Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 23, 2023 - 10:13 GMT
Scheduled
This notification is to inform you of planned maintenance work being carried out by our supplier.
Please be advised that our Support Teams are undertaking maintenance on the Pilot platform which is expected to end today at 17:00 GMT. This will be for the Pilot site only.
Posted Nov 23, 2023 - 10:10 GMT
This scheduled maintenance affected: GBG ID3global (ID3global Portal).