Service Disruption -Loqate Utilities Register - Electricity & Gas

Incident Report for GBG

Postmortem

The cause of this issue has been confirmed by our suppliers to be due to exceptionally high traffic volumes, following the recent Ofgem energy price cap announcement. This led to service instability, and customers will have received errors and delayed responses to requests.

 

During the course of this incident, GBG was fully engaged in discussions with the suppliers and their governing body to ensure service levels were restored as quickly as possible.

 

We will continue to monitor closely, and will be working with our suppliers to drive performance improvements over the coming weeks and months.

 

GBG would like to apologise for the impact this may have had on your business, and we thank you for your patience.

 

GBG would welcome feedback from you in respect of this incident - here's a very short survey - GBG survey

Posted Feb 28, 2025 - 08:54 GMT

Resolved

We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 09:11 – 19:50 GMT DATE 26/02/2025 - 27/02/2025
Posted Feb 28, 2025 - 08:34 GMT

Update

We are continuing to work on a fix for this issue.
Posted Feb 27, 2025 - 18:02 GMT

Update

Although there has been some service performance improvement this afternoon, you may still experience some errors and delays to requests. GBG is continuing to actively monitor and remains engaged with the supplier.
Posted Feb 27, 2025 - 15:13 GMT

Update

We are continuing to work on a fix for this issue.
Posted Feb 27, 2025 - 12:06 GMT

Update

Our supplier has confirmed that the ongoing issues are connected to exceptionally high traffic volumes as a result of Ofgem’s recent energy price cap announcement. Errors and latency are expected to continue in the short term. GBG is continuing to monitor this closely, and we remain engaged in discussions with our suppliers. Thank you for your patience.
Posted Feb 27, 2025 - 08:50 GMT

Update

Our supplier has noted some performance improvements this afternoon and is actively monitoring and working to stabilise the service. GBG remains fully engaged with the supplier.

Next update will be provided tomorrow morning, 27th February 2025.
Posted Feb 26, 2025 - 16:49 GMT

Update

We continuing to engage with our supplier for resolution of this issue. We would like to thank you for your patience during this time.
Posted Feb 26, 2025 - 13:43 GMT

Update

Our supplier is investigating this issue as a priority. We will continue to provide updates as things progress.
Posted Feb 26, 2025 - 11:28 GMT

Update

Investigations are continuing. We are actively working with our suppliers to ensure this is resolved as quickly as possible.
Posted Feb 26, 2025 - 10:02 GMT

Identified

We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Feb 26, 2025 - 09:18 GMT
This incident affected: Loqate (Utilities Register - Gas, Utilities Register - Electricity).