Degraded Service - ExpectID

Incident Report for GBG

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 23:45 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2025 - 22:01 BST

Investigating

We are currently investigating this issue.
Posted Oct 08, 2025 - 21:50 BST
This incident affected: GBG ExpectID (Portal, API, Reports, ExpectID Number Verification, ExpectID Barcode Scan, ExpectID Scan Verify, ExpectID Secure OTV, ExpectID Business, ExpectID Death Scrub, ExpectID Email, ExpectID Geotrace, ExpectID International, ExpectID IQ, ExpectID Mobile Attributes, ExpectID Age Verification, ExpectID PA, ExpectID Name to Phone, ExpectID PA Global, ExpectID Scan Onboard, ExpectID Trust USA, ExpectID).