Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 23, 2023 - 15:00 BST
Scheduled
This notification is to inform you of planned maintenance work being carried out by our supplier.
Services Impacted: All illion Databases Country: AU & NZ Outage Start Date and Time: Sunday 24th September 2023 00:00 AEDT (02:00 NZDT) Outage End Date and Time: Sunday 24th September 2023 02:00 AEDT (04:00 NZDT)
During the dates/times specified, the service will be unavailable and failures will occur for the below item checks.
Posted Sep 20, 2023 - 00:51 BST
This scheduled maintenance affected: GreenID (ASIC Personal Name Search, Australian Claims Database, illion Australian Credit Header, Australian Tenancy File, Data Co-Op Database, FCS Public Number Directory, FCS NAD File, NZTA NZ Drivers Licence, illion NZ Credit Header, FCS illion Data Sources, AU Credit Simple).