This incident has been resolved. Document/s Affected - Visa Start Date and Time - 25 February 2026 — 10:29AM AEDT End Date and Time - 25 February 2026 — 5:23PM AEDT
Posted Feb 25, 2026 - 21:41 GMT
Investigating
Transactions involving VISA (DVS) may intermittently fail. Start Date & Time: 25 February 2026, 10:29 AM AEDT Further updates will be provided as soon as more information becomes available.
Posted Feb 24, 2026 - 23:53 GMT
This incident affected: GBG Cloudcheck (Australian Visa).