Service Disruption - ID3global - Germany Credit (0401)

Incident Report for GBG

Resolved

We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 08:51 GMT 10/02/2025 – 09:53 GMT 12/02/2025
Posted Feb 12, 2025 - 11:45 GMT

Update

We are continuing to work on a fix for this issue.
Posted Feb 12, 2025 - 09:34 GMT

Update

Our engineering team are continuing to work with our data supplier to find a resolution to this issue.
Posted Feb 11, 2025 - 18:27 GMT

Update

We are continuing to work on a fix for this issue.
Posted Feb 11, 2025 - 15:31 GMT

Update

Our engineering team are currently working with our data supplier to obtain a resolution to this issue.
Posted Feb 11, 2025 - 09:30 GMT

Update

We are continuing to work on a fix for this issue.
Posted Feb 10, 2025 - 19:00 GMT

Update

We are continuing to work on a fix for this issue in conjunction with our data supplier.
Posted Feb 10, 2025 - 17:03 GMT

Identified

We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Feb 10, 2025 - 13:52 GMT
This incident affected: GBG ID3global (Germany Credit (0401)).