Service Disruption - ID3global/URU - All Services
Incident Report for GBG
Postmortem

GBG undertakes security patching each month to remain up to date and compliant. In order to ensure that this does not normally affect our customers the implementation process moves our customers’ transactional traffic around the Production platform to the resilience capacity available.

On the 23rd the Secondary SQL Server had been patched and rebooted and was observed to be using all the read capacity of it’s connected drives.  This was unusual and flagged an investigation and log review. At 16:09 the log drive connected to the SQL Server began to experience the same ‘high volume of read’ – this effectively prevented our SQL Database from processing any transactions. While this impact was only occurring on the secondary SQL server it meant that any transactions attempting to be committed to the database were blocked, thereby affecting our primary SQL Server.

GBG implements its security patching through stages of its production systems – through our development, non-production, Disaster Recovery and then Production sites – with validation and delays between each stage. This problem was not seen in other environments.

GBG has raised a problem case with our Cloud provider to support explaining this unusual behaviour. We are working with them to understand if there is an environmental or patch related issue.

Posted Feb 03, 2023 - 10:47 GMT

Resolved
We're pleased to inform you that the service disruption has now been resolved and users should be able to use the system as normal. A root cause analysis report containing further detail around the problem cause and resolution will be shared with you shortly.

The incident duration was between 16:09-16:31 GMT on 23/01/2023.

To customers that have been affected by this issue, we would again like to apologise.
Posted Jan 23, 2023 - 16:37 GMT
Update
We are continuing to investigate this issue.
Posted Jan 23, 2023 - 16:30 GMT
Investigating
We are investigating an issue affecting our service. We apologise for the impact this may be having on your business. Our Incident Team is working to identify the root cause and implement a solution as a priority. We hope to advise you within a few minutes that the issue has been resolved, should this not be the case we will provide a further update and estimated resolution time at 17:00 on 23/01/2023.
Posted Jan 23, 2023 - 16:28 GMT
This incident affected: GBG ID3global (ID3global Portal, URU Portal, ID3global Service, URU Service).