Service Disruption - ID3 Sweden Personal ID (0215) / Population (0213) / Population (DOB) (0214)
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 14:42 BST – 15:31 BST 04/09/2020
Posted Sep 04, 2020 - 15:52 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Sep 04, 2020 - 15:07 BST
This incident affected: GBG ID3global (Sweden Personal ID (0215), Sweden Population (0213), Sweden Population (DOB) (0214)).