Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 03, 2025 - 14:00 BST
Scheduled
This notification is to inform you of planned maintenance work being carried out by our supplier.
Start time: Saturday, May 03, 2025, 23:00 Sydney Australia time. Estimated finish time: Saturday, May 04, 2025, 07:00 Sydney Australia time. Estimated Duration: 8 hours |
During the dates/times specified, the service will be unavailable and failures will occur for the below item checks.
Posted Apr 17, 2025 - 04:07 BST
This scheduled maintenance affected: GreenID (Experian Australian Credit Header).