Service Disruption - Identity Solution - Germany Schuffa ID Premium (0228)
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 12:48 – 14:38 BST 25/06/2020
Posted Jun 25, 2020 - 16:13 BST
Monitoring
We believe this service issue is resolved.

However, we are monitoring the item check closely to ensure the service is functioning as expected.
Posted Jun 25, 2020 - 15:45 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Jun 25, 2020 - 13:07 BST
This incident affected: GBG Identity Solution (Germany Schufa ID Premium (0228)).