Retrospective Service Disruption - ID3Global - 0404 - Canada Credit (FINTRAC)
Incident Report for GBG
Postmortem

Our supplier experience a network issue which affected the transactions, leading to timeouts or failures to respond during the incident period.  The supplier support teams on call responded and corrected the issue, resolving the impact to their customers. 

The supplier has escalated the issue to their vendor and there is a planned upgrade/fix to be deployed on 6/6/22 in resolution

Posted May 30, 2022 - 10:09 BST

Resolved
Please be advised that we experienced a service disruption that may have prevented you from accessing or processing transactions.

The incident duration was between 17:38 - 18:12 May 18, 2022 (BST)

To customers that have been affected by this issue, we would like to apologise. If you need to speak to us regarding this notification, please contact the Helpdesk on *0844 888 1136 or ID3globalhelp@gbgplc.com
*calls cost 5p per minute plus your telephone company’s network access charge
Posted May 19, 2022 - 02:39 BST
This incident affected: GBG ID3global (Canada Credit (Fintrac) (0404)).