Unfortunately, the service issue is ongoing. We continue to treat this matter as our top priority and all technical teams are working to determine the cause and resolution. We apologise that this issue is taking longer to resolve than we would like.
Posted Mar 12, 2025 - 20:00 GMT
Identified
Unfortunately, the service issue is ongoing. We continue to treat this matter as our top priority and all technical teams are working to determine the cause and resolution. We apologise that this issue is taking longer to resolve than we would like.
Thank you for your continued patience.
Posted Mar 12, 2025 - 17:08 GMT
Investigating
We are investigating an issue affecting our service. We apologise for the impact this may be having on your business. Our Incident Team is working to identify the root cause and implement a solution as a priority. We hope to advise you within a few minutes that the issue has been resolved, should this not be the case we will provide a further update and estimated resolution time at 17:00 GMT 12/03/2025
Posted Mar 12, 2025 - 16:37 GMT
This incident affected: GBG ProID (ProID Portal v2).