Service Disruption - IDscan - FDE/Scannet Live Support
Incident Report for GBG
Resolved
This incident has been resolved. We apologise for any inconvenience caused during this outage.
Posted Aug 03, 2022 - 09:17 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our LiveSupport service. We apologise for any inconvenience this may cause.
Posted Aug 03, 2022 - 08:48 BST
This incident affected: GBG IDscan (Forensic Document Customer Service (Scannet - Live Support)).