Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 31, 2025 - 11:00 BST
Scheduled
This notification is to inform you of planned maintenance work being carried out by our supplier.
Data Source impacted: Credit File Header Country: AU and NZ Outage Start Time: Saturday 31st May 2025 at 8:00 PM AEST Outage End Time: Sunday 1st June 2025 at 12:00 AM AEST
During the dates/times specified, the service will be unavailable and failures will occur for the below item checks.
Posted May 21, 2025 - 02:53 BST
This scheduled maintenance affected: GreenID (illion Australian Credit Header, illion NZ Credit Header).