Service Disruption - ID3Global/URU Platforms
Incident Report for GBG
Postmortem

Dear Customers,

At 9:23am on 14/7/2021 our monitoring triggered alerts that our primary data centre was not handling transactions. Resolver teams were investigating within 5 minutes and determined that some unknown physical or network issue was affecting the primary site. This was escalated to our provider to investigate.

While this investigation was ongoing GBG discovered that the synchronized database was affected to had to prepare for a manual fail-over to our secondary site. The preparation of this took longer than normal execution of failover as the state of the database needed to be verified.

The manual process was started at 1045 and completed at 1058. From this point customers would have been able to transact with the platform.

We apologise for any inconvenience caused during this incident.

Posted Jul 22, 2021 - 16:13 BST

Resolved
We're pleased to inform you that the service disruption has now been resolved and users should be able to access the portal and complete transactions as normal.

We have failed over from our primary to our secondary site. This took longer than usual as the other site was unavailable. The team have performed all necessary tests and have signed off to say this is now working as expected.

A root cause analysis report containing further detail around the problem cause and resolution will be shared with you shortly.

Incident duration 09:32 - 10:58 BST 14/07/2021

To customers that have been affected by this issue, we would again like to apologise.
Posted Jul 14, 2021 - 11:03 BST
Identified
Initial investigations have determined that we have lost connection to our Primary site. We are working with our service provider to fix the issue.

Users may be experiencing connectivity issues preventing access to the portal and timeouts when processing transactions.

Unfortunately we are unable to provide a fix ETA at the moment.

We will update you at 11:30 BST 14/07/2021 or as soon as the issue is resolved.

Thank you for your patience whilst we restore our service back to our usual level.
Posted Jul 14, 2021 - 10:30 BST
Investigating
We are investigating an issue affecting our service. We apologise for the impact this may be having on your business. Our Incident Team is working to identify the root cause and implement a solution as a priority. We hope to advise you within a few minutes that the issue has been resolved, should this not be the case we will provide a further update and estimated resolution time at 10:30 BST 14/07/2021
Posted Jul 14, 2021 - 09:43 BST
This incident affected: GBG ID3global (ID3global Portal, URU Portal, ID3global Service, URU Service).