Service Disruption - ID3 Global - 0216 - Norway Population
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between *01:17 – *02:41 GMT 18/03/2020
Posted Mar 18, 2020 - 05:28 GMT
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Mar 18, 2020 - 01:50 GMT
This incident affected: GBG ID3global (Norway Population (0216)).