Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 17, 2025 - 08:00 GMT
Scheduled
Please be advised that GBG Support teams will be performing essential maintenance during this time. All core Loqate services will remain up and operational, however, customers may experience some minor disruption or increased latency whilst this takes place. This maintenance is vital to ensure the stability and reliability of Loqate services.
Posted Jan 14, 2025 - 12:06 GMT
This scheduled maintenance affected: Loqate (Verify).