We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.
The incident duration was between 19/01/2026 approx. 15:50 GMT– 28/01/2026 approx. 06:30 GMT
Our internal teams are continuing to work with our supplier to ensure the stability of the service.
Posted Jan 28, 2026 - 17:48 GMT
Update
The team have been focused today on resolving the ongoing service issue.
I’m sorry for the length of time the issue is taking to resolve and the inconvenience caused. We are still unable to give an estimated fix time and date at this time
Thank you for your continued patience.
Posted Jan 27, 2026 - 12:42 GMT
Investigating
We are currently experiencing a service disruption that is affecting a component used within this product. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Jan 26, 2026 - 12:16 GMT
This incident affected: GBG GO Platform (Data Verification - Colombia: Single match, Data Verification (Dual Match) - Colombia: Dual match).