Service Disruption - Loqate / Utilities Register - Electricity
Incident Report for GBG
Postmortem

Root cause analysis confirms that this was a supplier issue. An unusual amount of API calls to the system resulted in performance degradation. Calls reduced to normal levels and service resumed.

We are working with the supplier to introduce preventative measures to prevent this from reoccurring.

GBG would welcome feedback from you in respect of this incident - here's a very short survey - GBG survey

Posted May 23, 2023 - 09:13 BST

Resolved
We're pleased to inform you that the service disruption has now been resolved and users should be able to use the system as normal.

The incident duration was between 16:18 BST – 16:58 BST 22/05/2023

To customers that have been affected by this issue, we would again like to apologise.
Posted May 22, 2023 - 17:07 BST
Investigating
Please be advised that GBG Support teams have identified an increase in system errors and/or latency which may cause brief interruptions to the Loqate services listed below.

We apologise for the impact this may be having on your business. Our incident team are working hard to identify and fix the root cause as quickly as possible. Further updates to follow.
Posted May 22, 2023 - 16:36 BST
This incident affected: Loqate (Utilities Register - Electricity).