Service Disruption - ID3global - UK Credit Header (0154/0155)
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption to the Credit Header advanced features we reported earlier is now resolved.

To customers that have been affected by this issue, we would like to apologise. If you need to speak to us regarding this notification, please contact the Helpdesk on *0844 888 1136 or ID3globalhelp@gbgplc.com
*calls cost 5p per minute plus your telephone company’s network access charge
Posted Nov 18, 2020 - 03:40 GMT
Update
We are continuing to work on a fix for this issue.
Posted Nov 18, 2020 - 02:24 GMT
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Nov 18, 2020 - 02:08 GMT
This incident affected: GBG ID3global (UK Credit Header (0154/0155), UK Credit Header (0154/0155) - Match level Advanced/Enhanced).