Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 02, 2025 - 09:30 BST
Scheduled
We have identified an issue relating to the UK Mobile Identity Verification (0543) item check that requires urgent maintenance. During this period there will be impacts to the following item checks while the change to address this is implemented :
UK Mobile Identity Verification (0543) Germany Mobile Identity Verification (0544) France Mobile Identity Verification (0545) Spain Mobile Identity Verification (0546) Canada Mobile Identity Verification (0547)
During the dates/times specified, the service will be unavailable and failures will occur for the below item checks.
We apologise for any inconvenience caused
Posted Jul 02, 2025 - 09:14 BST
This scheduled maintenance affected: GBG ID3global (UK Mobile Identity Verification (0543), Germany Mobile Identity Verification (0544), France Mobile Identity Verification (0545), Spain Mobile Identity Verification (0546), Canada Mobile Identity Verification (0547)).