Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 18, 2023 - 13:00 GMT
Scheduled
This notification is to inform you of planned maintenance work being carried out by our supplier.
Description: Centrelink Concession Cards Start Date: Sunday 19th of November 2023 12:00:00 AM AEDT End Date: Sunday 19th of November 2023 6:00:00 AM AEDT
During the dates/times specified, the service will be unavailable and failures will occur for the below item checks.
Posted Nov 16, 2023 - 02:35 GMT
This scheduled maintenance affected: GreenID (DVS - Centrelink Concession Card).