Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 15, 2023 - 11:00 BST
Scheduled
This notification is to inform you of planned maintenance work being carried out by our supplier.
Environment • Production Document • Immigration documents Date • Friday 15 September to Saturday 16 September 2023 Time • 9:00pm Friday to 6:00am Saturday AEST
During the dates/times specified, the service will be unavailable and failures will occur for the below item checks.
Posted Sep 13, 2023 - 04:29 BST
This scheduled maintenance affected: GreenID (DVS - Immigration Documents (Visa / Immicards / Citizenship / Registration by Descent)).