Service Disruption - Telephone number not functional (0800 198 6460)
Incident Report for GBG
Resolved
We’re pleased to inform the Loqate support telephone number 0800 198 6460 is now available to use once again.
Thank you for your understanding.
Posted Aug 09, 2022 - 09:37 BST
Identified
We are currently experiencing a service disruption with the Loqate support telephone number (0800 198 6460).
We apologise for this inconvenience, please use 01244 657 321 instead whilst we rectify this issue. Thank you for your understanding.
Posted Aug 03, 2022 - 11:51 BST