Service Disruption - ID3global / 0404 Canada FINTRAC
Incident Report for GBG
Resolved
This incident has been resolved.

GBG would like to apologise for any inconvenience caused during this time.
Posted Jun 26, 2022 - 11:44 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Jun 26, 2022 - 09:19 BST
This incident affected: GBG ID3global (Canada Credit (Fintrac) (0404)).