Retrospective Service disruption - ID3global / URU Platforms
Incident Report for GBG
Postmortem

Dear Customers,

On Wednesday 22nd of July between 13:51- 14:01, we experienced a Priority One incident on the ID3global/URU Platform.

Our Service Provider regularly deploys changes to our datacentres, these changes vary from adding a new IP range for our suppliers, reacting to a vulnerability or identifying changes that need to be made to our Infrastructure.

The issue occurred during an approved network change to their Datacentres. The implementation was applied to our standby site and proven but during the same process on the Live site a human error was made which caused a site outage.

The impact to our service for our customers means that ID3global was inaccessible completely for 10 minutes. GBG were alerted by our monitoring and we raised this to the Service Provider. Whilst the investigation took place, we failed over to the secondary LIVE site.

Due to the issue being cause by our provider we are working with them to automate manual processes

We apologise for the inconvenienced caused

Posted Aug 07, 2020 - 11:57 BST

Resolved
Please be advised that we experienced a service disruption that may have resulted in customers receiving errors accessing our ID3global & URU platforms.

The incident duration was between 13:51 – 14:01 BST 22/07/2020

To customers that have been affected by this issue, we would like to apologise. If you need to speak to us regarding this notification, please contact the helpdesk on *0844 888 1136 or ID3globalhelp@gbgplc.com *calls cost 5p per minute plus your telephone company’s network access charge
Posted Jul 22, 2020 - 14:09 BST
This incident affected: GBG ID3global (ID3global Portal, URU Portal, ID3global Service, URU Service).