Service Disruption - ID3 Global / Malaysia Financial (354)
Incident Report for GBG
Resolved
This incident has been resolved.
Posted Jun 20, 2022 - 10:12 BST
Update
We are happy to advise the service is now working
Posted Jun 12, 2022 - 17:02 BST
Investigating
We are investigating an issue affecting our service. We apologise for the impact this may be having on your business. Our Incident Team is working to identify the root cause and implement a solution as a priority. We hope to advise you within a few minutes that the issue has been resolved, should this not be the case we will provide a further update and estimated resolution time at 17:00 BST 12/06/22
Posted Jun 12, 2022 - 15:52 BST
This incident affected: GBG ID3global (Malaysia Financial (0354)).