Service Disruption - ID3 UK Bank Account Verification (0261) / UK Geo Lifestyle (0322)
Incident Report for GBG
Resolved
We're pleased to inform you that the service disruption has now been resolved and users should be able to use the system as normal. A root cause analysis report containing further detail around the problem cause and resolution will be shared with you shortly.

The incident duration was between ENTER TIME 13:32 – 15:31 11-10-2021

To customers that have been affected by this issue, we would again like to apologise.
Posted Oct 11, 2021 - 16:02 BST
Update
Our data supplier is continuing to investigate this issue.
Posted Oct 11, 2021 - 15:19 BST
Update
We have confirmed there is an issue with our data supplier for these item checks.
Posted Oct 11, 2021 - 14:27 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Oct 11, 2021 - 13:48 BST
This incident affected: GBG ID3global (UK Bank Account Verification (0261), UK Geo Lifestyle (0322)).