Service Disruption - ID3 Malaysia Financial (0354)
Incident Report for GBG
Resolved
On 13/5/22 our supplier for these services made a security update to remove TLS 1.0 and TLS 1.1 and associated ciphers that support it. GBG had seen this change in the suppliers test environment and tested and saw no issues. However on that date of the live implementation we lost service for the Malaysian Financial data.

Investigation with the supplier identified that they had applied the strictest decisions on which ciphers could be used for TLS 1.2 or above. What this meant for ID3global is that there was no common ciphers held by both GBG and Supplier over which to establish a secure connection. Without a secure connection (which is a standard requirement for GBG to talk to its suppliers) GBG cannot send our customer data to the supplier. GBG has escalated this with the supplier with suggestions to allow certain other ciphers to support but our supplier cannot change its security stance.

At the moment GBG systems have no additional ciphers or capability to add additional due to the software versions of Windows on our servers. We are in a process of migrating to Azure Cloud and at that time we will be able to connect securely again with the supplier. We apologise but in the meantime GBG will not be able to process transactions through to our supplier for Malaysia Financial transactions. Any requests made by our customers will return the result code 9999 – a ‘Fatal Error’ response due to being unable to connect.

We will provide an update when this service becomes available and apologise again for this extended and continuing service interruption.
Posted Jun 01, 2022 - 14:25 BST
Update
We are continuing to work on a fix for this issue.
Posted May 27, 2022 - 16:16 BST
Update
We are continuing to work on a fix for this issue.
Posted May 25, 2022 - 08:55 BST
Update
Our platform team continue to be in contact with our supplier to find a resolution for this issue.
Posted May 23, 2022 - 09:27 BST
Update
We are continuing to work on a fix for this issue.
Posted May 20, 2022 - 09:03 BST
Identified
We are continuing to work with our data supplier for a fix on this issue following identification of the issue.
Posted May 19, 2022 - 08:55 BST
Update
We are currently still investigating this issue with our data supplier and our platform team.
Posted May 16, 2022 - 17:35 BST
Investigating
We are currently investigating this issue.
Posted May 16, 2022 - 09:52 BST
This incident affected: GBG ID3global (Malaysia Financial (0354)).