Service Disruption - Identity as a Solution - Verify Person
Incident Report for GBG
Resolved
We're pleased to inform you that the service disruption has now been resolved and users should be able to use the system as normal.

The incident duration was between 18.55 – 19.31 BST 17/09/20

To customers that have been affected by this issue, we would again like to apologise. If you need to speak to us regarding this issue, please contact the helpdesk on *0844 888 1136/01244 657321 helpdesk@gbgplc.com
Posted Sep 17, 2020 - 19:42 BST
Investigating
We are investigating an issue affecting our service. We apologise for the impact this may be having on your business. Our Incident Team is working to identify the root cause and implement a solution as a priority.
Posted Sep 17, 2020 - 19:22 BST