Service Disruption - ID3Global / Norway
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported previously is now resolved. Thank you for your patience whilst we restored service.

The incident duration was between 01:00 BST 28/05/2021 – 12:30 BST 31/05/2021
Posted May 31, 2021 - 19:32 BST
Update
Our supplier has identified the root cause of this issue and is currently working for a fix to this issue.
Posted May 31, 2021 - 08:59 BST
Update
We are continuing to work on a fix for this issue.
Posted May 30, 2021 - 09:30 BST
Update
We are continuing to work on a fix for this issue.
Posted May 29, 2021 - 09:21 BST
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted May 28, 2021 - 19:10 BST
This incident affected: GBG ID3global (Norway Landline (0218), Norway Landline (Telephone) (0224), Norway Landline DOB (0222), Norway Marketing (0217), Norway Marketing DOB (0221), Norway Mobile (0219), Norway Mobile (Telephone) (0225), Norway Mobile DOB (0223), Norway Mortality (0226), Norway Population (0216), Norway Population (DOB) (0220)).