Service Disruption - 348 - Czech Republic Population
Incident Report for GBG
Resolved
We’re pleased to inform you that the service disruption we reported earlier is now resolved. Thank you for your patience whilst we restored service.
Incident duration 14/01/2020 20:23 GMT - 15/01/2020 00:08 GMT
Posted Jan 15, 2020 - 05:42 GMT
Identified
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Jan 15, 2020 - 00:34 GMT
This incident affected: GBG ID3global (Czech Republic Population (0348)).