Service Disruption - ID3 Global Platform Issue
Incident Report for GBG
Resolved
We're pleased to inform you that the service disruption has now been resolved and users should be able to access the portal and/or complete transactions as normal.

To customers that have been affected by this issue, we would again like to apologise.
Posted Sep 29, 2022 - 09:49 BST
Identified
We are continuing to investigate the issue which is causing slower transactions and some fatal error for our customers. While we have seen a slight improvement/reduction in issues we are continuing to investigate to correct the issue.

We will update you at 10:30 or as soon as the issue is resolved. Thank you for your patience whilst we restore our service back to our usual level.
Posted Sep 29, 2022 - 09:34 BST
Investigating
We are investigating an issue affecting our service. We apologise for the impact this may be having on your business. Our Incident Team is working to identify the root cause and implement a solution as a priority. We hope to advise you within a few minutes that the issue has been resolved, should this not be the case we will provide a further update and estimated resolution time at 09:30 BST on 29/09/2022
Posted Sep 29, 2022 - 09:04 BST
This incident affected: GBG ID3global (ID3global Portal, ID3global Service, URU Service).