Certificate - idmp.gb.co.uk is currently Unavailable.
Incident Report for GBG
Resolved
This incident has been resolved.
Posted May 13, 2020 - 08:43 BST
Investigating
Incident Reason : Unable to connect the host
Incident Time : May 13, 2020 8:35 AM BST
We are currently experiencing a service disruption that may be preventing you from using our service. We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted May 13, 2020 - 08:35 BST