Service Disruption - ID3Global / URU
Incident Report for GBG
Resolved
We're pleased to inform you that the service disruption has now been resolved and users should be able to use the system as normal. A root cause analysis report containing further detail around the problem cause and resolution will be shared with you shortly.

The incident duration was between 18.55 – 19.31 BST 17/09/20

To customers that have been affected by this issue, we would again like to apologise. If you need to speak to us regarding this issue, please contact the helpdesk on 0844 888 1136 or ID3globalhelp@gbgplc.com
Posted Sep 17, 2020 - 19:41 BST
Investigating
We are investigating an issue affecting our service. We apologise for the impact this may be having on your business. Our Incident Team is working to identify the root cause and implement a solution as a priority. We hope to advise you within a few minutes that the issue has been resolved, should this not be the case we will provide a further update and estimated resolution time at 19.45 BST
Posted Sep 17, 2020 - 19:13 BST
This incident affected: GBG ID3global (ID3global Portal, URU Portal, ID3global Service, URU Service).