Service Disruption - greenID Business Verification
Incident Report for GBG
Resolved
This incident has been resolved.
Posted Nov 01, 2021 - 06:14 GMT
Monitoring
A fix has been implemented and we are monitoring the results.

Thank you for your patience.
Posted Oct 26, 2021 - 01:03 BST
Identified
Dear Customer,

We are currently experiencing intermittent errors that may be preventing you from using our Business Verification service.

We’re sorry for the impact this may be having on your Business and we’re working hard to get this back up and running.
Posted Oct 18, 2021 - 03:08 BST
This incident affected: GreenID (GreenID Business Verification).