Notification of Planned Maintenance - ID3 Checks – New Zealand 313,315,317 and Australia 357
Scheduled for May 24, 07:00 - 16:00 BST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 21, 2022 - 08:06 BST
Scheduled
GBG will be implementing a change to the ID3Global service during this time which will improve how we handle certain item checks. You may experience a brief up-to 5 minute interruption to service whilst this is being deployed but the service will otherwise be fully operational as normal. No other GBG services are affected by this. GBG would like to apologise for any inconvenience caused during this time
Posted May 23, 2022 - 16:15 BST
This scheduled maintenance affects: GBG ID3global (Australia Marketing (0357), New Zealand DIA Passport (0317), New Zealand Property (0313), New Zeland DIA Birth (0315)).